import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\s*(\\d+)\\s*(.*\\S) .*(?:\\R\\h*+(?!F\\d{6}\\b).*)*\\R\\h*(F\\d{6})";
final String string = " 1 DOPPEL TYP I MEERBLICK HALBPENSION\n"
+ " FRĂHBUCHER 20%\n"
+ " INKL. REISELEITUNG UND TRANSFER AB/BIS\n"
+ " FLUGHAFEN\n"
+ " KEIN INFO-TREFFEN IM HOTEL! REISELEITUNG IST TELEFONISCH ZU ERREICHEN UND AUF ANFRAGE\n"
+ " F367655 HERR WILKAT, CHRISTINE O 05.01.15\n"
+ " F367655 HERR LEBEDIES, HANS-JOACHIM O 05.01.15";
final Pattern pattern = Pattern.compile(regex, Pattern.UNICODE_CASE);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}