#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)Announced<\/a><\/td>\n<td class=\"nfo\">(.*?)<\/td>"
Local $sString = "<tr>" & @CRLF & _
"<th rowspan="2" scope="row">Launch</th>" & @CRLF & _
"<td class="ttl"><a href=# onClick="helpW('h_year.htm');">Announced</a></td>" & @CRLF & _
"<td class="nfo">2014, December</td>" & @CRLF & _
"</tr>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")