import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "Announced<\\/a><\\/td>\\n<td class=\\\"nfo\\\">(.*?)<\\/td>";
final String string = "<tr>\n"
+ "<th rowspan=\"2\" scope=\"row\">Launch</th>\n"
+ "<td class=\"ttl\"><a href=# onClick=\"helpW('h_year.htm');\">Announced</a></td>\n"
+ "<td class=\"nfo\">2014, December</td>\n"
+ "</tr>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}