// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)Announced<\/a><\/td>\n<td class=\"nfo\">(.*?)<\/td>"#).unwrap();
let string = "<tr>
<th rowspan=\"2\" scope=\"row\">Launch</th>
<td class=\"ttl\"><a href=# onClick=\"helpW('h_year.htm');\">Announced</a></td>
<td class=\"nfo\">2014, December</td>
</tr>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}