$re = '/Announced<\/a><\/td>\n<td class=\"nfo\">(.*?)<\/td>/m';
$str = '<tr>
<th rowspan="2" scope="row">Launch</th>
<td class="ttl"><a href=# onClick="helpW(\'h_year.htm\');">Announced</a></td>
<td class="nfo">2014, December</td>
</tr>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);