# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/((?:(?!<[\/]mark\s*>).){0,5})<mark\s*>([^<]*)<[\/]mark\s*>(?=((?:(?!<mark\s*>).){0,5}))/\n$1 $2 $3\n/gi;t' <<< "Lorem ipsum mark> <MARK >dolor</MARK > < mark sitamet. <mark>Lorem</mark> ipsum again and <mark>dolor</mark>.
um <mark>dolor</mark> sit amet. <mark>Lorem</mark> ipsum again and <mark>dolor</mark>.
um <mark>dolor</mark> sit <test amet. <mark>Lorem</mark> ipsum again and <mark>dolor</mark>.
Lorem ipsum <MARK >dolor</MARK > sit <mark>amet.</mark><mark>Lorem</mark> ipsum again and <mark>dolor</mark>."