re = /((?:(?!<[\/]mark\s*>).){0,5})<mark\s*>([^<]*)<[\/]mark\s*>(?=((?:(?!<mark\s*>).){0,5}))/i
str = 'Lorem ipsum mark> <MARK >dolor</MARK > < mark sitamet. <mark>Lorem</mark> ipsum again and <mark>dolor</mark>.
um <mark>dolor</mark> sit amet. <mark>Lorem</mark> ipsum again and <mark>dolor</mark>.
um <mark>dolor</mark> sit <test amet. <mark>Lorem</mark> ipsum again and <mark>dolor</mark>.
Lorem ipsum <MARK >dolor</MARK > sit <mark>amet.</mark><mark>Lorem</mark> ipsum again and <mark>dolor</mark>.'
subst = '\\n$1 $2 $3\\n'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result