const regex = /((?:(?!<[/]mark\s*>).){0,5})<mark\s*>([^<]*)<[/]mark\s*>(?=((?:(?!<mark\s*>).){0,5}))/gi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('((?:(?!<[\/]mark\\s*>).){0,5})<mark\\s*>([^<]*)<[\/]mark\\s*>(?=((?:(?!<mark\\s*>).){0,5}))', 'gi')
const str = `Lorem ipsum mark> <MARK >dolor</MARK > < mark sitamet. <mark>Lorem</mark> ipsum again and <mark>dolor</mark>.
um <mark>dolor</mark> sit amet. <mark>Lorem</mark> ipsum again and <mark>dolor</mark>.
um <mark>dolor</mark> sit <test amet. <mark>Lorem</mark> ipsum again and <mark>dolor</mark>.
Lorem ipsum <MARK >dolor</MARK > sit <mark>amet.</mark><mark>Lorem</mark> ipsum again and <mark>dolor</mark>.`;
const subst = `\n$1 $2 $3\n`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);