#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^([a-zA-Z' ]+)\s+([0-9a-z, ]+)$"
Local $sString = "Sokolov 19, 20, 23 ,25" & @CRLF & _
"Hertzl 80,82,84,86" & @CRLF & _
"Hertzl 80a,82b,84e,90" & @CRLF & _
"Aba Hillel Silver 2,3,5,6," & @CRLF & _
"Weizman 8" & @CRLF & _
"Ahad Ha'am 9 13 29"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")