re = /^([a-zA-Z' ]+)\s+([0-9a-z, ]+)$/m
str = 'Sokolov 19, 20, 23 ,25
Hertzl 80,82,84,86
Hertzl 80a,82b,84e,90
Aba Hillel Silver 2,3,5,6,
Weizman 8
Ahad Ha\'am 9 13 29'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end