import re
regex = re.compile(r"^([a-zA-Z' ]+)\s+([0-9a-z, ]+)$", flags=re.MULTILINE)
test_str = ("Sokolov 19, 20, 23 ,25\n"
"Hertzl 80,82,84,86\n"
"Hertzl 80a,82b,84e,90\n"
"Aba Hillel Silver 2,3,5,6,\n"
"Weizman 8\n"
"Ahad Ha'am 9 13 29")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")