const regex = /(?s)From:((?!From:).)*?Subject:/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?s)From:((?!From:).)*?Subject:', '')
const str = `From: h
From:b
xyz
Subject: testing`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}