re = /(?s)From:((?!From:).)*?Subject:/
str = 'From: h
From:b
xyz
Subject: testing'
# Print the match result
str.match(re) do |match|
puts match.to_s
end