$re = '/(?s)From:((?!From:).)*?Subject:/';
$str = 'From: h
From:b
xyz
Subject: testing';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);