import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\d{1,2}\\/\\d{1,2}|https:\\/\\/docs\\.google\\.com\\/spreadsheet\\/ccc\\?key=[\\w\\n]*&usp=drive_web&pli=1#gid=\\d{1,}";
final String string = "Hi All\n"
+ " \n"
+ " 12/14日訂購的廠商為 一品魯肉飯 \n"
+ " \n"
+ "請於下列連結中登記\n"
+ " \n"
+ "https://docs.google.com/spreadsheet/ccc?key=0AgZpbYtnWitPdDNjWFp4aG9yVm1IQlFWaldlTU5MSXc&usp=drive_web&pli=1#gid=126\n"
+ " \n"
+ "請於上午10:10前登記完成, 逾時不候.\n"
+ " \n"
+ "============================================================================================\n"
+ " \n"
+ "12/15日訂購的廠商為 北一排骨便當 \n"
+ " \n"
+ "請於下列連結中登記\n"
+ " \n"
+ "https://docs.google.com/spreadsheet/ccc?key=0AgZpbYtnWitPdDNjWFp4aG9yVm1IQlFWaldlTU5MSXc&usp=drive_web&pli=1#gid=138\n"
+ " \n"
+ " \n"
+ "請於上午10:10前登記完成, 逾時不候.\n"
+ " \n"
+ "謝謝您的配合";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}