const regex = /\d{1,2}\/\d{1,2}|https:\/\/docs\.google\.com\/spreadsheet\/ccc\?key=[\w\n]*&usp=drive_web&pli=1#gid=\d{1,}/gi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\d{1,2}\\\/\\d{1,2}|https:\\\/\\\/docs\\.google\\.com\\\/spreadsheet\\\/ccc\\?key=[\\w\\n]*&usp=drive_web&pli=1#gid=\\d{1,}', 'gi')
const str = `Hi All
12/14日訂購的廠商為 一品魯肉飯
請於下列連結中登記
https://docs.google.com/spreadsheet/ccc?key=0AgZpbYtnWitPdDNjWFp4aG9yVm1IQlFWaldlTU5MSXc&usp=drive_web&pli=1#gid=126
請於上午10:10前登記完成, 逾時不候.
============================================================================================
12/15日訂購的廠商為 北一排骨便當
請於下列連結中登記
https://docs.google.com/spreadsheet/ccc?key=0AgZpbYtnWitPdDNjWFp4aG9yVm1IQlFWaldlTU5MSXc&usp=drive_web&pli=1#gid=138
請於上午10:10前登記完成, 逾時不候.
謝謝您的配合`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}