import re
regex = re.compile(r"\d{1,2}\/\d{1,2}|https:\/\/docs\.google\.com\/spreadsheet\/ccc\?key=[\w\n]*&usp=drive_web&pli=1#gid=\d{1,}", flags=re.IGNORECASE)
test_str = ("Hi All\n"
" \n"
" 12/14日訂購的廠商為 一品魯肉飯 \n"
" \n"
"請於下列連結中登記\n"
" \n"
"https://docs.google.com/spreadsheet/ccc?key=0AgZpbYtnWitPdDNjWFp4aG9yVm1IQlFWaldlTU5MSXc&usp=drive_web&pli=1#gid=126\n"
" \n"
"請於上午10:10前登記完成, 逾時不候.\n"
" \n"
"============================================================================================\n"
" \n"
"12/15日訂購的廠商為 北一排骨便當 \n"
" \n"
"請於下列連結中登記\n"
" \n"
"https://docs.google.com/spreadsheet/ccc?key=0AgZpbYtnWitPdDNjWFp4aG9yVm1IQlFWaldlTU5MSXc&usp=drive_web&pli=1#gid=138\n"
" \n"
" \n"
"請於上午10:10前登記完成, 逾時不候.\n"
" \n"
"謝謝您的配合")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")