using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\[amenities (.*?)\]";
string input = @" Input: BEST AVAILABLE RATE , [Amenities BREAKFAST] , [amenities WIFI] AND FITN ? - MORE IN HP ";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}