package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)\[amenities (.*?)\]`)
var str = ` Input: BEST AVAILABLE RATE , [Amenities BREAKFAST] , [amenities WIFI] AND FITN ? - MORE IN HP `
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}