using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"@L@.*?@R@|(in)";
string input = @"This is a @L@string@R@ and it's @L@good or ok@R@ to change characters in the next string";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}