re = /@L@.*?@R@|(in)/m
str = 'This is a @L@string@R@ and it\'s @L@good or ok@R@ to change characters in the next string'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end