package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)@L@.*?@R@|(in)`)
var str = `This is a @L@string@R@ and it's @L@good or ok@R@ to change characters in the next string`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}