$re = '/@L@.*?@R@|(in)/m';
$str = 'This is a @L@string@R@ and it\'s @L@good or ok@R@ to change characters in the next string';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);