#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\((\d+), 2020"
Local $sString = "(190497, 2020, 'FedEx First Overnight', '2', '2', NULL, 1, 'lb', 'letter', NULL, 55.35, NULL, NULL, NULL, NULL)," & @CRLF & _
"(190498, 2020, 'FedEx Priority Overnight', '2', '2', NULL, 1, 'lb', 'letter', NULL, 25.35, NULL, NULL, NULL, NULL)," & @CRLF & _
"(190499, 2020, 'FedEx Standard Overnight', '2', '2', NULL, 1, 'lb', 'letter', NULL, 24.85, NULL, NULL, NULL, NULL)," & @CRLF & _
"(190500, 2020, 'FedEx 2Day AM', '2', '2', NULL, 1, 'lb', 'letter', NULL, 19.40, NULL, NULL, NULL, NULL)," & @CRLF & _
"(190501, 2020, 'FedEx 2Day', '2', '2', NULL, NULL, 'lb', 'letter', NULL, NULL, NULL, NULL, NULL, NULL),"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")