import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\((\\d+), 2020";
final String string = "(190497, 2020, 'FedEx First Overnight', '2', '2', NULL, 1, 'lb', 'letter', NULL, 55.35, NULL, NULL, NULL, NULL),\n"
+ "(190498, 2020, 'FedEx Priority Overnight', '2', '2', NULL, 1, 'lb', 'letter', NULL, 25.35, NULL, NULL, NULL, NULL),\n"
+ "(190499, 2020, 'FedEx Standard Overnight', '2', '2', NULL, 1, 'lb', 'letter', NULL, 24.85, NULL, NULL, NULL, NULL),\n"
+ "(190500, 2020, 'FedEx 2Day AM', '2', '2', NULL, 1, 'lb', 'letter', NULL, 19.40, NULL, NULL, NULL, NULL),\n"
+ "(190501, 2020, 'FedEx 2Day', '2', '2', NULL, NULL, 'lb', 'letter', NULL, NULL, NULL, NULL, NULL, NULL),";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}