use strict;
my $str = '(190497, 2020, \'FedEx First Overnight\', \'2\', \'2\', NULL, 1, \'lb\', \'letter\', NULL, 55.35, NULL, NULL, NULL, NULL),
(190498, 2020, \'FedEx Priority Overnight\', \'2\', \'2\', NULL, 1, \'lb\', \'letter\', NULL, 25.35, NULL, NULL, NULL, NULL),
(190499, 2020, \'FedEx Standard Overnight\', \'2\', \'2\', NULL, 1, \'lb\', \'letter\', NULL, 24.85, NULL, NULL, NULL, NULL),
(190500, 2020, \'FedEx 2Day AM\', \'2\', \'2\', NULL, 1, \'lb\', \'letter\', NULL, 19.40, NULL, NULL, NULL, NULL),
(190501, 2020, \'FedEx 2Day\', \'2\', \'2\', NULL, NULL, \'lb\', \'letter\', NULL, NULL, NULL, NULL, NULL, NULL),';
my $regex = qr/\((\d+), 2020/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}