#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^6\d{8}$"
Local $sString = "# Invalid" & @CRLF & _
"" & @CRLF & _
"61234" & @CRLF & _
"6123456789" & @CRLF & _
"6word7890" & @CRLF & _
"" & @CRLF & _
"12688684749" & @CRLF & _
"" & @CRLF & _
"# Valid" & @CRLF & _
"688684749" & @CRLF & _
"678684749" & @CRLF & _
"651684749" & @CRLF & _
"652684749" & @CRLF & _
"653684749" & @CRLF & _
"654684749" & @CRLF & _
"698684749" & @CRLF & _
"655684749" & @CRLF & _
"656684749" & @CRLF & _
"657684749" & @CRLF & _
"658684749"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")