const regex = /^6\d{8}$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^6\\d{8}$', 'gm')
const str = `# Invalid
61234
6123456789
6word7890
12688684749
# Valid
688684749
678684749
651684749
652684749
653684749
654684749
698684749
655684749
656684749
657684749
658684749`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}