$re = '/^6\d{8}$/m';
$str = '# Invalid
61234
6123456789
6word7890
12688684749
# Valid
688684749
678684749
651684749
652684749
653684749
654684749
698684749
655684749
656684749
657684749
658684749';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);