# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^6\d{8}$"
test_str = ("# Invalid\n\n"
"61234\n"
"6123456789\n"
"6word7890\n\n"
"12688684749\n\n"
"# Valid\n"
"688684749\n"
"678684749\n"
"651684749\n"
"652684749\n"
"653684749\n"
"654684749\n"
"698684749\n"
"655684749\n"
"656684749\n"
"657684749\n"
"658684749")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.