import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\s+by\\s+)(?<alias>[a-zA-Z-]{3,22})\n";
final String string = " --> Triage: (nothing) -> Approved\n"
+ "===== Edited by dhaffner on 06/18/2015 10:42AM =====";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}