re = /(\s+by\s+)(?<alias>[a-zA-Z-]{3,22})
/
str = ' --> Triage: (nothing) -> Approved
===== Edited by dhaffner on 06/18/2015 10:42AM ====='
# Print the match result
str.match(re) do |match|
puts match.to_s
end