import re
regex = re.compile((r"(\s+by\s+)(?<alias>[a-zA-Z-]{3,22})\n"))
test_str = (" --> Triage: (nothing) -> Approved\n"
"===== Edited by dhaffner on 06/18/2015 10:42AM =====")
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")