// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(\s+by\s+)(?<alias>[a-zA-Z-]{3,22})
").unwrap();
let string = " --> Triage: (nothing) -> Approved
===== Edited by dhaffner on 06/18/2015 10:42AM =====";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}