import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = ".*(SomeMethod)\\s([^']+)\\s.*";
final String string = "SomeMethod x, 5, True 'Optional Comments\n\n"
+ "**SomeMethod x, 5, True 'Optional Comments that I don't mind throwing away if it makes things easier";
final String subst = "$1($2)";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}