// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r".*(SomeMethod)\s([^']+)\s.*").unwrap();
let string = "SomeMethod x, 5, True 'Optional Comments
**SomeMethod x, 5, True 'Optional Comments that I don't mind throwing away if it makes things easier";
let substitution = "$1($2)";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}