$re = '/.*(SomeMethod)\s([^\']+)\s.*/';
$str = 'SomeMethod x, 5, True \'Optional Comments
**SomeMethod x, 5, True \'Optional Comments that I don\'t mind throwing away if it makes things easier';
$subst = "$1($2)";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;