const regex = /.*(SomeMethod)\s([^']+)\s.*/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('.*(SomeMethod)\\s([^\']+)\\s.*', 'g')
const str = `SomeMethod x, 5, True 'Optional Comments
**SomeMethod x, 5, True 'Optional Comments that I don't mind throwing away if it makes things easier`;
const subst = `$1($2)`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);