using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=_adv_)[\w\W]*?(?=_)";
string input = @" _adv_1_
Lorem ipsum dolor sit amet, consectetur adipisicing elit. Commodi consequuntur cumque eligendi et facilis ipsa perferendis possimus quasi quidem, quod rem, suscipit voluptas. Asperiores assumenda nemo repellat rerum sint, sunt?
_adv_2_
Lorem ipsum dolor sit amet, consectetur adipisicing elit. Commodi consequuntur cumque eligendi et facilis ipsa perferendis possimus quasi quidem, quod rem, suscipit voluptas. Asperiores assumenda nemo repellat rerum sint, sunt?";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}