import Foundation
let pattern = #"(?<=_adv_)[\w\W]*?(?=_)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
_adv_1_
Lorem ipsum dolor sit amet, consectetur adipisicing elit. Commodi consequuntur cumque eligendi et facilis ipsa perferendis possimus quasi quidem, quod rem, suscipit voluptas. Asperiores assumenda nemo repellat rerum sint, sunt?
_adv_2_
Lorem ipsum dolor sit amet, consectetur adipisicing elit. Commodi consequuntur cumque eligendi et facilis ipsa perferendis possimus quasi quidem, quod rem, suscipit voluptas. Asperiores assumenda nemo repellat rerum sint, sunt?
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)