using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=\s|^)#([^\d_\s\W][\p{L}\d]{2,})";
string input = @"#hello #world, this is from http://stackoverflow.com/questions/29996848#question-header looks like it #works.";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}