$re = '/(?<=\s|^)#([^\d_\s\W][\p{L}\d]{2,})/';
$str = '#hello #world, this is from http://stackoverflow.com/questions/29996848#question-header looks like it #works.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);