import Foundation
let pattern = ##"(?<=\s|^)#([^\d_\s\W][\p{L}\d]{2,})"##
let regex = try! NSRegularExpression(pattern: pattern)
let testString = ##"#hello #world, this is from http://stackoverflow.com/questions/29996848#question-header looks like it #works."##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)