re = /(?<=\s|^)#([^\d_\s\W][\p{L}\d]{2,})/
str = '#hello #world, this is from http://stackoverflow.com/questions/29996848#question-header looks like it #works.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end