#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "<a.*(\[nggallery[^\]+]*\]).*?<\/a>"
Local $sString = "<a href="[nggallery id=xx]"><span class="shutterset"><img class="alignnone size-large wp-image-23067" title="Image Title" src="http://example.com/wp-content/uploads/2015/06/image-title.jpg" alt="" width="685" height="456" /></span></a>" & @CRLF & _
" " & @CRLF & _
"<a href="[nggallery id=xxxxx]">Click here!</a>" & @CRLF & _
" " & @CRLF & _
"<a title="title title" href="[nggallery id=xxx]" target="_blank">Title Link Title Link</a>"
Local $sSubst = "$1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)