import re
regex = re.compile(r"<a.*(\[nggallery[^\]+]*\]).*?<\/a>")
test_str = ("<a href=\"[nggallery id=xx]\"><span class=\"shutterset\"><img class=\"alignnone size-large wp-image-23067\" title=\"Image Title\" src=\"http://example.com/wp-content/uploads/2015/06/image-title.jpg\" alt=\"\" width=\"685\" height=\"456\" /></span></a>\n"
" \n"
"<a href=\"[nggallery id=xxxxx]\">Click here!</a>\n"
" \n"
"<a title=\"title title\" href=\"[nggallery id=xxx]\" target=\"_blank\">Title Link Title Link</a>")
subst = "$1"
result = regex.sub(subst, test_str)
if result:
print(result)