const regex = /<a.*(\[nggallery[^\]+]*\]).*?<\/a>/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<a.*(\\[nggallery[^\\]+]*\\]).*?<\\\/a>', 'g')
const str = `<a href="[nggallery id=xx]"><span class="shutterset"><img class="alignnone size-large wp-image-23067" title="Image Title" src="http://example.com/wp-content/uploads/2015/06/image-title.jpg" alt="" width="685" height="456" /></span></a>
<a href="[nggallery id=xxxxx]">Click here!</a>
<a title="title title" href="[nggallery id=xxx]" target="_blank">Title Link Title Link</a>`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);