use strict;
my $str = '@john camel07 st.doe!';
my $regex = qr/[^a-zA-Z ]/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";