import re
regex = re.compile(r"[^a-zA-Z ]")
test_str = "@john camel07 st.doe!"
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)