$re = '/[^a-zA-Z ]/';
$str = '@john camel07 st.doe!';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;